Sizzle 1.0.4
A library for querying XML documents by means of CSS 2.1 selectors

Sizzle is a library for querying XML documents by means of CSS 2.1 selectors.

Sizzle currently supports:

  • The Universal selector - *
  • Type selectors - div
  • ID selectors - #id
  • Class selectors - .heading
  • Descendant selectors - html div
  • Child selectors - html > div
  • Adjacent sibling selectors - div + p
  • Any value attribute selector - [att]
  • Exact value attribute selector - [att=val]
  • Whitespace value attribute selector - [att~=val]
  • Language value attribute selector - [att|=val]
  • The pseudo-class :first-child
  • The language pseudo-class :lang(xxx)

Bonus CSS3 selectors:

  • The pseudo-class :last-child
  • The pseudo-class :nth-child(n) (basic numeric implementation)
  • The pseudo-class :nth-last-child(n) (basic numeric implementation)

Note: Sizzle has no association with Sizzle - The JavaScript CSS Selector Engine as used by JQuery. Well, except for the name of course!

Read more...

Install

To install Sizzle with Fantom Pod Manager, cut'n'paste the following into a cmd prompt, terminal or shell:

Or to install Sizzle with the Fantom Repository Manager (fanr), cut'n'paste the following into a cmd prompt, terminal or shell:

Or to install manually, download the pod file and copy it to the %FAN_HOME%/lib/fan/ directory.

afSizzle.pod (35.00 kB)

Use

To use Sizzle in a Fantom project, add a dependency to the project's build.fan:

depends = ["sys 1.0", ..., "afSizzle 1.0.4 - 1.0"]

Documentation

Information

Meta information on the Sizzle pod:

Published by
Steve Eynon
Organisation
Alien-Factory
Pod file size
35.00 kB
Licence
ISC Licence (ISC)
Built on
11th Oct 2017
Source code
via Mercurial at https://bitbucket.org/AlienFactory/afsizzle
Depends on
sys, xml
Referenced by
afBedNap, afBounce
Javascript Compatible
No

Dependency Graph

  Use mouse to re-position pods

Release History

There have been 6 releases of Sizzle: